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Using the Update
Manager

By means of the Update Manager you can perform software updates at regular intervals. It is

possible to let ARCWAY Cockpit search for updates automatically.
You can also use the Update Manager to install new features or modules that are not

contained in the standard installation.

Updating installed Features

To check to see whether there are updates for a product's existing features (requires internet

access):

1. Click Help > Software Updates > Find and Install... in the main menu and select
Search for Updates of the currently installed features in the following dialog.
This will contact the Web sites associated with the product's features to discover what

versions of those features are available. The potential upgrades are presented in on

the next page.

Updates |:|@
Search Results _
e

Select features to install from the search result list, ') —!
.

Deselect Al

More Info

Select the features ko install;

= [« B it Update Site
| U ARCWAY Cockpit 3.0
= ARCWAY Cockpit Document Module 3.0.37
ARCWAY Cockpit Issue Module 3.0,37 Brameriies
ARCYAY Cockpit Requirement Module 3.0.57 —
W ARCWAY Cockpit Use Case Module 3.0,37
ARCWAY Cockpit BPRE Event-Driven Process Chain Diagram suppark 3.0,37
S ARCWAY Cockpit Standalone 3,037

Error Detals,

ARCWAY, net Cockpit Update Site
6 of & selected,

Show the |akest version of a feature anly
[ Filter patches included in okher patches on the list

2. Select the feature versions that you wish to upgrade, and click Next.




3.

%AF{CWAY

Carefully review the license agreements for the upgraded features. If the terms of all

these licenses are acceptable, check | accept the terms in the license agreements.

Features with not accepted license agreements can not be installed.

Feature License

Some of the features have license agreements that wou need to accept before proceeding with the

£

installation, =
K- ARCWAY Cockpit Document Modu| | MOTES FOR USE it !
G )
::?:g ARCUAY Cockpft Issue. hcle Use of the Software is subject to the Contractual Terms between
’3-:" ARCWAY Cockpit Requirement Mol | apcway 4G and the Client, extracts of which are reproduced below,
Kk ARCWAY Cockpit Use Case Modul| | Reproduction is solely For information purposes. Only the agreed
@ARCWAY Cockpit BPRE Event-Driv conditions of use are binding, Accardingly only emplovees of
F . the client are entitled to use the software within the agreed
P ARCWAY Cockpit Standalone 3.0.| | - one of the licence. Please make sure before instaling the

Software that your emplover has obtained. a valid licence or evaluation

licence From ARCWAY AG,

Any unauthorised use of this software constitutes an infringement

of these conditions of use and the copyright of ARCWAY AG and

may lead to legal action being taken against the unauthorised

user, Please contack ARCWAY AG, Alt-Moabit 90b, D-10559 Berlin

if wou have any guestions regarding the scope of the licence,

2 1. Right ko use the Software &z

()1 accept the terms in the license agreements

()1 do not accept the terms in the license agreements

Cancel

4. The Install Location page controls where the new feature's files are to be installed on

the local computer. Select the directory into which the product is installed and hit

Next. (If the product is installed in a directory to which you do not have write access,

you should contact your system administrator and get them to install this feature so
that it will be generally available. The other option is to click Add and point to a

directory to which you do have write access.

Installation

Feature will be installed.

Features to jnstall:

The Following Features will be installed. You can select a Feature and change the location where the

e d
D

Feature Name

Feature Yersion Installation Direckary

'-;'%ARCWAV Cackpit BPRE Event-Driven Proc...
'-EII'SARCWAV Cockpit Dacument Module
’-i‘\f:':ARCWAV Cockpit Issue Module
'-{‘f."eARCWAV Cockpit Requirement Module

(g2 ARCWAY Cockpit Standalons

<

3.0.37 1 Programme (AR CWAY TARCWAY Cﬁci
30,37 JC: {Programme] ARCWAYTARCWAY Coc|
30,37 ICProgramme AR CWAYIARCWAY Coc%
30,37 ICProgramme ARCWAYARCWAY Cocé
3.0.37

ICProgrammeARCYWAYTARCWAY Co
Ak ATTTE,

3|

Install Location:

Required space: Unknown
Fres space: 14,44 GB

CHProgrammel ARCWAYIARCWAY Cockpit Professional 3.0

Change Location ...
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Click Finish to allow the downloading and installing to proceed.

Feature versions can be digitally signed by the company that provides them. This
allows you to verify more easily that the features and plug-ins that are about to be

downloaded and installed are coming from a trusted supplier.

Warning: Because of the possibility of harmful or even malicious plug-ins, you should
only download features from parties that you trust. Features that have been provided

by ARCWAY are always trustworthy.

Click Install or Install All to allow the downloading and installing to proceed.

Feature Yerification _ '

15, ‘Warning: You are about to install an unsigned Feature, e
?)

~ You may choose ba install the Feature or cancel iks inskallation, B

This feature has not been digitally signed.
The provider of this Feature cannot be verified.

Feature name: ARCWAY Cockpit Document Module
Feature Identifier: com.arcway.cockpit.documentmodule_3.0.37
Prowider: ARCWAY AG

File Identifiet! com.arcway.cockpit.documentmodule_3.0.37

[ Install H Install Al ]uancel |

Once all the features and plug-ins have been downloaded successfully and their files
installed, a new configuration that incorporates these features and plug-ins will be
formulated. Click Yes when asked to exit and restart the Workbench for the changes
to take effect. After restarting you can continue working with your updated version of

ARCWAY Cockpit.
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Installing new Features

To locate and install a new feature into your Cockpit (ordinarily requires web access):

1. Perform an update (see Updating installed features) to make sure that the new
features are compatible with your version of ARCWAY Cockpit.

2. Open the Install Wizard by clicking Help > Software Updates > Find and Install...

in the main menu.
3. Select the second button Search for new features to install and click Next.

4. Create a bookmark for an update site where Cockpit features and plug-ins are
published. In the sites to search list, select
= New Remote Site to add a remote site
* New Local Site if the site is available on a local drive (including a CD)
= New Archived Site, when the site is available locally but is packaged as a

jar or zip file.

Install |Zl@®
Update sites to visit ¢
pdate sites to visi (L J

Select update sites b visit while looking For new Features,

0 B

Sites ko include in search:

MNew Remoke Site. ..
Mewe Local Site. ..
Mew grchived Site., .,

Import sites. ..

Ignore Features not-applicable to this environment

[J automatically select mirrors

Mext = Firish Cancel
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In most cases you will install your new feature from a remote site that has been
provided by ARCWAY.

You can find a list of all features that are currently provided by us and can be installed
using the Update Manager under Additional Features.

In the new update site dialog, give the site a name such as "Use Case Module" and

enter the URL or the path to the local site, such as

"http://update.arcway.net/updates/cockpit/3.1/usecasemodule/".

Update sites to visit - ]

Select update sites to wisit whils looking For new Features, \"'

Sites ko include in search!

New Update 5ite

Mame: | Use Case Module | j

URL: |p:,l',l'update.arcway.net,l'updates,l'cockpit,l'S.l,fusecasernc-dule,l' |

[,_OK ” Cancel ]
‘ Impart sites...

Ignore Features not applicable to this enviranment

1 Automatically select mirrars

After adding the site click Finish. This will contact the web site to discover what
features are available.

Wait for the search to finish and select the features to be added. You can view the
description or more detailed properties for any feature by selecting the feature and

pressing the Properties button.
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Updates |z|@

Search Results
Select feakures to install From the search result sk, ¥

(o ]
2 Deselect Al

=[] 000 ARCYAY Cockpit 3.1
o [W] 45 ARCWAY Cockpit Use Case Module 3,10.9 i

Select the Features to install:

Select Required

ARCWAY net Cockpit Update Sike

1 of 1 selecked,
Show the latest version of a feature only

[ Filker Features inchuded in ather Features on the list

Once you've decided which features to install, click Next.

Carefully review the license agreements for the features. If the terms of all these
licenses are acceptable, check | accept the terms in the license agreement.

Features with not accepted license agreements can not be installed.

Install

Feature License

Some of the Features have license agreements that wou need to accept
before proceeding with the installation.

LI+ ARCWAY Cockpit Lise ¢ | NOTES FOR, ISE ” I

Use of the Software is subject to the Contractual
Terms between

ARCWAY A and the Client, extracts of which are
reproduced below,

Repraduction is solely for information purposes.
COnly the agreed

conditions of use are binding. Accardingly anly
employess of

the client are entitled to use the software within the
agreed

scope of the licence, Please make sure before

< | # | | installing the “

@5;[ accept the terms in the license agreement:

()1 do nat accept the terms in the license agreement

[ < Back ][ hext = Einlsh

10
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10. If a feature selected for installing includes optional features, a page will show up

allowing you to select whether you want them to be installed or not. Optional
features typically carry functionality that is not essential for proper functioning of the

main feature.

. The Install Location page controls where the new feature's files are to be installed on

the local computer. Select the directory into which the product is installed and hit
Next. (If the product is installed in a directory to which you do not have write access,
you should contact your system administrator and get them to install this feature so
that it will be generally available. The other option is to click Change Location... and

Add and point to a directory to which you do have write access.

Install |z|.
Installation h 4—|

L
The Following Features will be installed. You can select a Feature and change the R
location where the Feature will be installed. H_J')l

Features to install:

Feature Mame Feature Yersion | Installation Directory |

3.10,9 1T IProgramme] AR

). | 2|

Install Location:  C:\Programmel ARCWAYIARCWAY Cockpit Profession | Change Location ..

Required space: Unknown
Free space: 14.62 GB

[ext = [ Einish H Cancel

12. Click Install to allow the downloading and installing to proceed.

13. Feature versions can be digitally signed by the company that provides them. This

allows you to verify more easily that the features and plug-ins that are about to be
downloaded and installed are coming from a trusted supplier.

Warning: Because of the possibility of harmful or even malicious plug-ins, you should
only download features from parties that you trust. Features that have been provided
by ARCWAY are always trustworthy.

Click Install to allow the downloading and installing to proceed.

11
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Feature Yerification

I, WWarning: You are about o install an unsigned Feature, gy
~ You may choose ko install the feature or cancel its installation, -")

This Feature has not been digitally signed.
The provider of this feature cannok be verified.

Feature name: ARCYWAY Cockpit Use Case Module
Feature Identifier: com.arcway.cockpit.usecasemodule_3.10.9
Provider: ARCWAY AG

File Identifier ! com.arcway.cockpit.usecasemodule_3.10.9

Inskall ] [ Irnskall Al

Once the new feature and plug-ins have been downloaded successfully and their files
installed into the product on the local computer, a new configuration that
incorporates these features and plug-ins will be formulated. Click Yes when asked to
exit and restart the workbench for the changes to take effect.

To add other new features at the same time before restarting, click No and repeat. If
this was a new feature and can be dynamically installed into the current
configuration, you will also be presented with an Apply Changes button. This will
not restart the platform, but configures the feature and the plug-ins into the current

configuration.

. New features may provide their own perspectives and views. To open a perspective

select Window > Open Perspective from the main menu and select the name of
the perspective. If the perspective is not available select Other... and select the
perspective from the following dialog. To open a view select Window > Show View
from the main menu and select the name of the view. Select Other... here as well if

the view is not available and select the view from the following dialog.

12
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Additional Features

You will find a list of features that you can use to extend your installation of ARCWAY
Cockpit. Furthermore the URL for the update site for each feature can be found. Contact our

support if you want to install a feature that has not been mentioned here.

Use Case Module

The Use Case Module manages textual descriptions of individual steps.

— Update Site: http://update.arcway.net/updates/cockpit/3.1/usecasemodule/

Document Module

The Document Module manages links to documents on the Web or in the file system.

— Update Site: http://update.arcway.net/updates/cockpit/3.1/documentmodule/

Plantype: UML Sequence Diagram
UML Sequence Diagrams show object interactions within a time sequence.
— Update Site: http://update.arcway.net/updates/cockpit/3.1/umisddiagrams/

Plantype: FMC Process Diagram (Petri Net)

FMC Petrinets model processes in a system.

— Update Site: http://update.arcway.net/updates/cockpit/3.1/fmcpndiagrams/
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